Sensible Daten verschlüsseln

Antwort

Die Verschlüsselung von Daten kann im Umgang mit personenbezogenen Informationen nötig sein. IDEA bietet eine Funktion, um sensible Daten sicher zu verschlüsseln. Für dieses Beispiel können Sie die Datei "Debitor_Daten.xls" verwenden. Sie finden sie in folgendem Verzeichnis:
"C:\Benutzer\\Dokumente\Meine IDEA Dokumente\Eigene IDEA Projekte\Samples\Quelldateien.ILB\"

Im Folgenden wird beschrieben, wie Sie ein geeignetes Feld (in diesem Beispiel das Feld "NAME") verschlüsseln:

  1. Öffnen Sie IDEA.
  2. Wählen Sie auf der Registerkarte Home in der Gruppe Import den Eintrag Desktop.
  3. Markieren Sie Microsoft Excel und wählen Sie die Datei "Debitor_Daten.xls" aus dem oben genannten Verzeichnis aus.
  4. Klicken Sie auf Weiter >.
  5. Wählen Sie als zu importierende Tabellen "Offene Rechnungen" und "Kunden Stammdaten" aus, indem Sie die entsprechenden Kontrollkästchen aktivieren.
  6. Aktivieren Sie das Kontrollkästchen Erste Zeile enthält die Feldnamen.
  7. Schließen Sie den Import mit OK ab.
  8. Laden Sie die benutzerdefinierten Funktionen EncryptString und DecryptString hier herunter und legen Sie sie in Ihrem aktuellen Projekt im Ordner "Benutzerdefinierte Funktionen.ILB" ab.
  9. Wählen Sie auf der Registerkarte Datei-Explorer die Datei "Debitor_Daten-Kundenstammdaten" aus und öffnen Sie sie mit einen Doppelklick.
  10. Klicken Sie auf der Registerkarte Daten, in der Gruppe Felder auf Anhängen.
  11. Vergeben Sie den Spaltennamen "NAME_CRYPT" und wählen Sie den Feldtyp "Rechenfeld-Zeichen" sowie die Länge "30" aus.
  12. Öffnen Sie den Gleichungseditor und geben Sie folgenden Parameter ein:
    #EncryptString(NAME)
  13. Beenden Sie die Verschlüsselung mit OK.


Entschlüsselung:

  1. Wählen Sie auf der Registerkarte Datei-Explorer die Datei "Debitor_Daten-Kundenstammdaten" aus und öffnen Sie sie mit einem Doppelklick.
  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Felder auf Anhängen.
  3. Vergeben Sie den Spaltennamen "NAME_DECRYPT" und wählen Sie den Feldtypen "Rechenfeld-Zeichen" sowie die Länge "30" aus.
  4. Geben Sie folgenden Parameter ein:
    #DecryptString(NAME_CRYPT)
  5. Beenden Sie den Vorgang mit OK.


Geben Sie Ihren eigenen Codeschlüssel in den Quellcode der benutzerdefinierten Funktion ein.

Codeschlüssel ändern:

  1. Öffnen Sie den Gleichungseditor.
  2. Klicken Sie auf Benutzerdefinierte Funktionen.
  3. Wählen Sie EncryptString aus und klicken Sie auf Bearbeiten.
  4. Ändern Sie den Codeschlüssel (in der Zeile "Festlegen des internen Codeschluessels"). Er kann aus einem beliebigen Wort oder Satz bestehen. Beachten Sie, dass der Codeschlüssel keine Leerzeichen enthalten darf.
  5. Verfahren Sie ebenso bei DecryptString.


Rechtlicher Hinweis: Für die Richtigkeit der Analysen Ihrer Daten kann keine Haftung seitens der Audicon GmbH übernommen werden. Zur Einhaltung datenschutzrechtlicher und betriebsinterner Privacy-Vorschriften empfehlen wir die Einrichtung eines dem Schutzniveau der Daten angemessenen Prüfungsprozesses sowie die Formulierung einer Vereinbarung mit Ihrem Betriebsrat und Ihrem Datenschutzbeauftragten.

Dieser Beitrag ist für folgende Versionen gültig:

IDEA 10.2 , IDEA 10.3
Email Drucken