Visuelle Makroerstellung

Antwort

Die visuelle Makroerstellung ermöglicht es Ihnen, wiederkehrende Arbeitsabläufe in IDEA zu automatisieren. Dazu müssen Sie den zu automatisierenden Ablauf bereits einmal in dem aktuellen Projekt abgeschlossen haben. In dem unten aufgezeigten Beispiel wird eine einfache Analyse erstellt: Es sollen alle Kunden angezeigt werden, bei denen die offenen Beträge in der Summe höher sind als das eingeräumte Kreditlimit. Grundlage für das Beispiel ist die Datei "Debitor_Daten.xls". Sie finden sie in folgendem Verzeichnis:
"C:\Benutzer\\Dokumente\Meine IDEA Dokumente\Eigene IDEA Projekte\Samples\Quelldateien.ILB\"

Und so geht's:

  1. Öffnen Sie IDEA.
  2. Wählen Sie auf der Registerkarte Home in der Gruppe Import den Eintrag Desktop.
  3. Markieren Sie Microsoft Excel und wählen Sie die Datei "Debitor_Daten.xls" aus dem oben genannten Verzeichnis aus.
  4. Klicken Sie auf Weiter >.
  5. Wählen Sie als zu importierende Tabellen "Offene Rechnungen" und "Kunden Stammdaten" aus, indem Sie die entsprechenden Kontrollkästchen aktivieren.
  6. Aktivieren Sie das Kontrollkästchen vor Erste Zeile enthält die Feldnamen.
  7. Schließen Sie den Import mit OK ab.
  8. Öffnen Sie im Datei-Explorer die Datei "Debitor_Daten-Offene Rechnungen" mit einem Doppelklick.
  9. Klicken Sie auf der Registerkarte Analyse in der Gruppe Kategorisieren auf den Eintrag Felder aufsummieren.
  10. Wählen Sie als Summenfeld "Betrag".
  11. Vergeben Sie den Dateinamen "Summe OP je Kunde" und schließen Sie den Dialog mit OK ab.
  12. Klicken Sie mit der rechten Maustaste im Datei-Explorer auf "Debitor_Daten-Kunden Stammdaten" und wählen Sie Mit geöffneter Datei verbinden…
  13. Wählen Sie für die Datei "Summe OP je Kunde" die Felder "KUNDENNR" und "BETRAG_SUMME" und für die Datei "Debitor_Daten-Kunden Stammdaten" die Felder "NAME" und "KREDITLIMIT".
  14. Klicken Sie auf Übereinstimmung und wählen Sie für beide Dateien das Schlüsselfeld "KUNDENNR" aus.
  15. Vergeben Sie als Dateinamen "Summe OP und KL" und schließen Sie das Verbinden der Dateien mit OK ab.
  16. Öffnen Sie im Bereich Eigenschaften mit einem Klick auf Kriterium den Gleichungseditor und geben Sie folgende Gleichung ein: BETRAG_SUMME > KREDITLIMIT.
  17. Schließen Sie den Gleichungseditor mit einem Klick auf Überprüfen und Schließen.
  18. Wählen Sie auf der Registerkarte Analyse in der Gruppe Extrahieren den Eintrag Direkt.
  19. Vergeben Sie den Namen "kritische Kunden" und erstellen Sie die Datei mit OK.

Dieser Ablauf soll nun als visuelles Makro automatisiert werden:

  1. Klicken Sie auf der Registerkarte Home in der Gruppe Projekte auf den Eintrag Projektübersicht.
  2. Wählen Sie im Menüband der Projektübersicht den Eintrag Makro erstellen.
  3. Markieren Sie "Datensatzextraktion kritische Kunden.IMD" und klicken Sie auf den Eintrag Vererbte Vorgänge markieren. Der gesamte Vorgang wird markiert.
  4. Klicken Sie auf die Schaltfläche Fertigstellen (hier besteht auch die Möglichkeit, das Makro in IDEASkript auf VB Basis zu speichern). In der Dialogbox der visuellen Skripterstellung können Sie die einzelnen Vorgänge verfolgen, ändern oder das gesamte Makro ausführen. Zusätzlich können Sie hier das generierte Makro für spätere Einsätze speichern.
  5. Klicken Sie im Menü Datei auf Speichern und geben Sie einen Namen ein.
  6. Schließen Sie sowohl die Dialogbox als auch die Projektübersicht.

Rechtlicher Hinweis: Für die Richtigkeit der Analysen Ihrer Daten kann keine Haftung seitens der Audicon GmbH übernommen werden.

Dieser Beitrag ist für folgende Versionen gültig:

Email Drucken